Results 1 to 3 of 3

Thread: Help! Chaos Gem Campaign Icon Not Showing

  1. Default Help! Chaos Gem Campaign Icon Not Showing

    Currently in the middle of a Chaos Gem Campaign for Typhonus. Already accomplished 33 million in damage but still no icon showing on my end (CA Name: Maria). The monster code is zg4iye1yq:3

    Please fix this. It's one of the steepest goals that I have seen once I started participating in Chaos Gem Campaigns again.
    Add us via army codes
    EDA6EB 051180 225FBE

    Join our slow kill group.
    https://www.facebook.com/groups/2145237929089027/

  2. #2

    Default

    Maybe try doing a tiny bit more damage?
    I think the healing you've done is taken into account for the total damage displayed. However I believe it doesn't count towards the actual damage requirement for Campaign. Maybe try doing 1 million more damage and see if if you still have no icon.

  3. Default

    Quote Originally Posted by gogoo View Post
    Maybe try doing a tiny bit more damage?
    I think the healing you've done is taken into account for the total damage displayed. However I believe it doesn't count towards the actual damage requirement for Campaign. Maybe try doing 1 million more damage and see if if you still have no icon.
    Thanks for the heads up
    Add us via army codes
    EDA6EB 051180 225FBE

    Join our slow kill group.
    https://www.facebook.com/groups/2145237929089027/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •