PDA

View Full Version : Generals not leveling



omegasam8
12-16-2009, 08:08 PM
Only so basically, I've been trying to get my Vanquish to lv 4 but... its exp bar isn't moving, even though I've quested with it and attacked dragons/ serpents for the past few days. Help? =/ [I have the same problem with Nautica]

omegasam8
12-17-2009, 08:21 PM
still not lvling =/

omegasam8
03-07-2010, 02:49 AM
its happening again but with other generals, someone help? >< plz?

Nafiza
03-07-2010, 03:01 AM
You've tried to level them up for days and nothing is happening?? :/
Try contacting support...
go to Castle Age, scroll down, on the bottom left will be "Contact" click it, and explain the situation to them, and they'll probably be best able to help you with the issue...
but I have never personally encountered the issue...some generals are just slow levelers though...I don't know how slow x.x; but slow...

Lady Denise
03-07-2010, 06:31 PM
I, too, have had trouble with Castle Age, I got a notice that said I opened a new demi quest, not sure if thats in a different level than the one I am in? I didnt think the level you were in made a difference. Also, I got a notice after leveling up that a new Hero or General was to be mine, but no, I got nothing! I even got a message that I didn't have the right general for the right quest, and I really did, I had just changed it before going into a quest and it was right there in from of my eyes. And, today, I got a message in battle that I was out of stamina, I did, in fact, have one left. Sorry to hear of your ordeal, I too have many in there, more as I level up..:confused: